Note: The Conferences i/o Mac App is in public beta. While the app has been tested by many customers, there can still be quirks or bugs that have not yet been ironed out. If you are using the Mac App and see any strange behavior, please email support@conferences.io.

Download and Installing the Mac App

 

Click here to download the Mac App 


Note: macOS 10.11 (El Capitan) or higher is required to run the app.


Updating to the latest version of our Mac App

If you've downloaded the Mac App on or after February 23, 2017, then you have a version that will automatically check for updates.


If you have an older version, then you will need to download the latest version, and remove the older version.


System requirements

The Conferences i/o Mac App works with macOS 10.11 (El Capitan) and higher. The app will not run on earlier versions of macOS.


This app is designed to work with Keynote or PowerPoint 2016 for Mac. Older versions of PowerPoint for Mac are not supported by this app.


Reminder: Our Mac App is a beta offering and you may encounter bugs or compatibility problems. If you do, please let us know by emailing support@conferences.io.